Sonos not working even with HTTP:// Live Radio Station - Encoding Error


#1

Hi, this looks like a great piece of software I would love to use with Sonos, but even if I add the HTTP Live Radio Station, it stops providing a “track is not encoded correctly” error.

I tried all format settings and MP3 PCM/L16

Any insights or help with this is greatly appreciated.


#2
  1. Download “Stream What You Hear” (http://www.streamwhatyouhear.com/)
  2. Go to your Sonos app on your PC and go to “Manage” –> “Add Radio Station…”
  3. Right click on your SWYH icon in the task bar and go to “Tools” -> “HTTP Live Streaming”
  4. Copy paste your streaming URL and enter the desired name and play!

#3

Unfortunately, though your instructions are quite simple, and the program appears to be so simply intentionally, its just not working.

Unable to play “Radio Station Name” - the track is not encoded correctly.


#4

I have same issue…

have tryed both stream settings (mp3 / pcm) same error.

Unable to play “Radio Station Name” – the track is not encoded correctly

I’m Running newest sonos firmware/software, newest SWYH and it rus on Windows 10 64 Bit


#5

I’m having the same issue. This should just be a feature of sonos. Going to return it today. I should have to jump through hoops to play sound from my computer.


#6

I have the exact same problem as above. I have win 10 64bit and Sonos Controller for PC ver 6.0 Build 31322220.

It just blows me away that Sonos would not want to be able to advertise that they can do this. If there is an opensource project that can perform this functionality maybe Sonos should get with them and work something out.

Can anyone from Streamwhatyouhear themselves possibly be able to assist us??


#7

Hello to the community
I started using SWYH three days ago and was able to feed my Sonos boxes. Two days ago, my Windows 10 underwent a major update and now I can’t connect to the stream server any more. Final message after a long timeout, whilest writing: “establishing connection” is: “connection to xxx.xxx.xxx.xxx:8080 impossible.”
My firewall is out of doubt, switched it off for the tests.
In certain cases I also saw the message of wrong encoding.
Am I alone with this? Help would be appreciated, as I don’t have knowledge of any similar product.
Michael


#8

To me it’s the same… I have done all instructions to get it started… I doesn’t want to start!


#9

By the way… wenn I start the link on my girlfriends notebook in Chrome it works.

So the connection link can’t be wrong or something


#10

Hello,

same error for me on a Windows 7 system with updated Sonos software.

Marc