Sonos IS supported!

Just installed it on a PC and it works fine.
You have to right-click on the SWYH icon, then select “settings”, check the box “use specific http port”, then go back to “tools” “http live streaming”
this shows a small screen on which you click “copy”
You go the Sonos app on the PC and select the “manage” menu, “add radio station” and paste this link.
The only issue is the 2 second delay.

hi,
it’s not possible to install SWYH for antivirus software, because it contains malware: CloudScanner.Trojan.Gen@2@ (should I uninstall my antivirus software???)
I’ve tried to find alternative download sites in several hours, nothing worked…
Any help?

I some how got this work but I hear sounds on both laptop and speakers which is rather annoying.

there’s malware included in the SWYH:
CloudScanner.Trojan.Gen@2@1
Any help?

I fixed ‘error coding’ message by doing the following:

  • copying streaming address by right-clicking on stream-what-you-hear icon and selecting Tools:HTTP Live Streaming

  • creating radio station on PC sonos software and pasting address

  • playing radio station on Sonos by selecting My-radio-stations and selecting the station I just created

I had the same problems.

To fix this I did as follows:

Go to Settings, - check user specific user HTTP ports and set to 5901.

Restart SWYH.

Paste: http://192.168.0.2:5901/stream/swyh.mp3 into the Sonos Radio sation as your streaming URL.

There is a delay, then works.

Regards, Richard.

Have just started using Stream What You Hear and am also experiencing a delay in audio when listening to Video sound tracks.
Easy solution is to use VLC media player and then go to Tools and the Track synchronisation.
I have found that if you put a negative delay of -1.500 seconds that the audio will then sync.
Mute your PC’s audio and then listen only to the SONOS players.
Have also discovered that if you Group your SONOS players and then play to the main grouped player then all SONOS players will play.

Hi, as all people here, i get really surprise not to be able to play youtube on my brand newPlay1. You really lost half the use of the stuff
It is weird to be told to buy the playbar to be able to get youtube via a cable and chromecast. First if i bought a play1 it is because i don’t have the money to buy a playbar or the sonos connect. Second it is stange to have a wireless solution and to be told to connect via a cable. That last one is really disapointing.

So I really thank people of Stream What your hear. They must be genius to be able to do thing that a big company cannot achieve with all there money and enginers.

To help others, the standard intall didnot work. So I try the stream via a radio creation (top post MAIK). This last one is working well. The 2 secondes delay is not an issue because I use my sonos to hear music in a different room.

a+

In principal it works for me, too! Thanks.

But my delay is not a mere 2 but 18 seconds!!

Any ideas re. the cause and how to resolve such a massive delay?

Thanks a lot

work great tanks

work great tanks

Is anyone having any trouble with the new sonos update and streamwhatyouhear working? I keep getting “source is not encoded correctly” on my sonos app

Thank you!! Fantastic to finally have this ability.

Like Anthony Namous, I got this to work by starting the stream from my Sonos PC controller software and clicking on my newly created SWYH station (stored in Music > Radio by TuneIn > My Radio Stations)

FYI, my SWYH settings are: Stream To: MP3; Capture: 48000 Hz, 16 bit, Stereo; MP3 Bitrate: 192; Specific HTTP Port: 5091.

Rubbish app. Sound quality is dreadful, sound delay and signal drops all the time.

This was the one. Thank you!

If the problem is “unable to connect”. It is probably a problem with the firewall. Go to the control panel, firewall and authorize the SWYH software.

1 Like

I hope Greig may be able to help me, as this follows on from his post of 2nd May.

I am using Stream What You Hear successfully, having followed Maik’s advice (thank you Maik!) - but I am struggling using VLC to beat “the delay”, which in my case is just on 3 seconds.

I can set up SWYH with the requisite delay, and I can set up my SWYH HTTP address as a Podcast address. I can also set up a Stream, but I am very unclear what settings to use. Trawling all over the net, I decided to ask VLC to stream to the IP address of my SONOS (192.168.1.160): but is this right? If I ought to be using the Streaming facility and not the Podcast, maybe the address should be that of SWYH’s HTTP address? Advice?

At present the problem that I THINK that I have is how to get a video clip, or a wireless stream that is playing happily on the SONOS from my desktop, to do so via VLC. In other words how to force VLC to become my default Media Player. But I may be wrong in thinking that!

The symptom I have is that I cannot get any of the buttons (play, pause etc) in the VLC dialogue to work. Is it possible that Adobe Flash Player has decided it is my default Media Player? That would be just like Adobe…

An additional twist is that I like to use Chrome as my browser. It seems to me that in any event I shall not be able to use Chrome with VLC after September, or whenever Google finally remove any aspect of NPAPI support (NB I have not a clue what NPAPI means, I just think it might be something to do with my problem - EXCEPT that I have tried with Internet Explorer as well, and can’t get what I want with that either). So I do accept that the best I may be able to achieve in any event is no delay if I use Internet Explorer only. Or Firefox of course.

Greig or anyone, I should be hugely grateful for your comments/advice!

Many thanks,

Edward

I get the error message, “Unable to play Stream What You Hear - Unable to connect to 192.168.1.173:5901”.

  • Running Windows 8.1.
  • Have two SONOS Play 1s
  • Set "Use specific HTTP port (tried both 8080 and 5901)
  • I’ve set firewall rules allowing SWYH (I think correctlY).
  • Created the station on SONOS, using the right IP and port
    Can anyone suggest what I’m doing wrong, or at least a way to track down my problem?

Hey,

It’s working but after a period of silence from the computer, SONOS stops playing the radio station.

Any ideas how to sort this so that SONOS keeps playing the radio even though there is no music/sound playing at the moment?

This is also an issue with playing your PC sound on the SONOS through Line-In on a Pair of SONOS Play:3, after a period of no sound, the speakers go into silent mode so that you will miss the start of when sound comes on again from the computer.

For Anyone Having issues with streaming coming up with improper coding right click the Stream what you hear icon and go to tools and then go to HTTP Live Streaming, Copy that address and in the Sonos Panel click Add Radio Station under the Manage drop down tool bar. paste the address there, and enter a name for the radio station that you will recognize. Then go to your the music part of your panel and click Radio by TuneIn, Then go to My Radio Stations and look for what ever you named the radio station, double click to start streaming the local radio and enjoy listening. Expect anywhere between 1 to 10 seconds of latency depending on your internet speed. Usually around 2 to 3. My friend had 14 seconds of latency. But of course he has a very slow internet speed and very bad router.