QED uPlay Stream


Has anyone been able to get Stream What You Hear to work with the QED uPlay Stream? I have an HP Pavilion laptop, and I am trying to stream to the uPlay using SWYH. The uPlay shows up as an option in the ‘Stream to’ list, but, when it is selected, the audio still comes from my laptop’s internal speakers. Sometimes, a loop is created, so that SWYH sends the audio to the internal speakers as well as the application I am running. I have tried YouTube, Spotify, VLC and WMP, but the result is the same. Used alone, WMP does stream to the uPlay, so the problem is not the unit. When WMP is running, it appears as an option in the SWYH ‘Stream to’ list, but no audio is received by WMP. If anyone has any suggestions I would be very grateful.


Update: I’ve noticed that when you send audio from the PC (running Windows 7) to the uPlay Stream via SWYH, after about 10 seconds you can hear a very brief burst of the audio, and then it stops. Simultaneously, the QED uPlay Stream unchecks itself in the ‘Stream to’ menu of SWYH. So it is possible to use the QED uPlay, just not for more than a fraction of a second. I’ve tried switching off the firewall, in case that was interfering, but it made no difference. Stereo mix is enabled on the laptop, and I’ve tried reinstalling SWYH. When you send audio to WMP via SWYH, and then try to use WMP to stream to the uPlay by playing the ‘swyh’ file in the playlist, WMP just says that “No media items are currently in the list” (although it will play them through the laptop’s internal speakers, so it does recognise the file in that situation). Is there anyone out there who knows how to fix this? I’ve a feeling the solution must be really simple… if only I could find it!