Problems streaming to Cambridge Audio Minx XI (from ver. 1.4)


#1

Hello and thanks for the wonderful tool - exactly the kind of thing I was looking for.
Unluckily it does not work with my streaming player - host pc: win 8.1 64 bit. Renderer: Cambridge Audio Minx XI amplifier.

  1. Select from The Minx XI control panel the SWYH device, MP3 stream => plays for only 5 secs, then stops with ‘end of queue’ message
  2. Select from The Minx XI the SWYH device, PCM stream => does not play
  3. Use the ‘Cambridge Connect’ app for Android, which acts as UPNP remote control to send music to the Minx XI: I can see the SWYH device, but the mp3/pcm streams are shown as folders, not tracks, and when I try to browse into them, the app just stalls :frowning:
  4. from the SWYH context menu, select the minx xi as streaming target => again, it seems to work for only 5 seconds

I have read from other forum posts that people have had success piping the SWYH stream into kodi or vlc, but I am honestly a bit loath to go down that path…

I am eager to contribute in any way - would wireshark captures be a good starting point?


#2

PS: I tried using Jamcast, which provides similar functionality to SWYH, and I had similar symptoms out of the box (‘end of queue’ error message).

Then I enable the ‘seek trick’ setting, and now it works.

I am not exactly sure what that is supposed to do, but in the release notes it is described as:

attempt to solve some playback compatibility issues with devices that seem to reject non-seekable content

Maybe this is enough of a tip to try to implement a similar workaround?