Problem with Sonos not connecting: symptoms, debugging, solution


Thought I’d mention a problem I encountered and solution I found trying to get Sonos to connect to SWYH in case it helps anyone else.

The issue was Sonos would not connect to SWYH on my new desktop, even though it worked on my old desktop. I eventually discovered that the new desktop has two places to plug the wired ethernet: one port made by Killer and the other by Intel. I was using the Intel port. Windows 10 decided that the Intel port was not a private network, and so blocked all incoming requests to that port. So, Sonos could not connect to SWYH. When I changed the type of port for the Intel connection from public to private, then it worked.

If you are having problems with Sonos not connecting to SWYH, here are some debugging suggestions I tried in case they are helpful.

  1. Turn off Windows 10 firewall temporarily, and see if it works then. If it does, then you know it’s a firewall issue. (This is what led me to discover that the Windows 10 was assigning the Intel port to be a public instead of private network.) Remember to turn the firewall back on when you are done debugging (and hopefully have gotten things working with the firewall on)!

  2. You should be able to open up a web browser on the machine running SWYH and type in JUST THE NUMEBERS BEFORE “/sream/swyh.mp3” and get a connection. I.e., if your entire SWYH URL looks like this: then type this into your browser: If SWYH is working, you will see a bunch of XML, and you can read down a bit and see things like “Stream What You Hear” so you know that SWYH is working. If instead you get and error such as “This site can’t be reached”, then SWYH is not running (you did turn off the Windows 10 firewall for debugging purposes, right?).

  3. Assuming you have a home wireless network and a laptop handy, open up a CHROME browser (not sure others work) on the laptop connected to your WiFi (NOT the machine you are running SWYH on). Type the SWYH URL directly into the browser’s address bar. You should hear the music from SWYH. If this doesn’t work, then something about your network is preventing access to SWYH (you did turn off the Windows 10 firewall for debugging purposes, right?)

Many thanks for making SWYH available!!


Testing out the browser connection idea, I also found that these also work:

  • Opera browser
  • Edge browser
  • Firefox browser (except you don’t get nicely formed XML but do see SWYH in the text)
  • wget from Windows cmd line
  • curl from Windows cmd line