How to force streaming on ethernet IP/interface, not VPN IP/interface


#1

PCs can have more than one active IP address. SWYH picks my VPN IP address to stream on, not the hardware ethernet IP address. Can I force it to not use that address and to use the proper one?

Thanks,
Marty


#2

Hi,

  • type “route print” in command prompt
  • note the lowest metric number
  • open your ethernet card properties
  • open TCP/IP v4
  • advanced
  • delete gateway if exist
  • untick automatic metric
  • enter the metric number you noted in command promt.

it should work


#3

Same problem, proposed solution does not work.
Any possibility to select the networkadapter manually?


#4

It worked for me. VPN-adapter had metric number 1. (so DNLA was actif on that network). I changed or better, I entered 1 in the metric setting of the desired network interface 'as sais above) . After restart of this programm (SWYH) the stream was send via correct (desired) network interface.