Works with SONOS!!


#1

Hi, I have no problem with straming to my SONOS-device.


#2

How? I am getting a coding error for swyh.wav (and swyh.mp3).


#3

Ok, got it from Sonos Forum.

You have to add a radio station.

For pcm you have to use swyh.wav.

Works like a charm - thank you very much for developing and providing this great piece of software!


#4

Stimmt im Sonos-Forum hatte ich es auch gepostet :slight_smile:

@Sebastien - Thank you too verry much for this tool. I testet hours with VLC. With SWYH it took me 5 minutes.


#5

SWYH and Sonos works like a charm with a newly created radio station. I’ve configured SWYH to always use the same port; so I should be able to use the same radio station in Sonos everytime I want to stream my PC sound.

But it rarely works to use an old station. Instead I have to go into Sonos and add a new radio station with the exact same URL as the old one.

Any ideas why this happens? (Some auxilary information: I have a Sonos bridge that is permanently connected to my home network. I run SWYH on up to 3 laptops simultaneously. The laptops travel around and move between different networks. I almost never rebot my laptops but they are quite often put to sleep during transportations. )


#6

Mikael Sjödin. most likely your router have DHCP and laptops get a different IP each time. Sonos might be looking up ip from name when you add only (guess) and then just use IP. At least this would explain.

Try to force laptops to always get same IP.


#7

Hi there,
I managed to pair SWYH with Sonos Connect too. Works well both with mp3 and pcm streaming.
The only problem is the quality of the sound. When I stream tracks through SWYH to Sonos, the sound totally lacks bass and low-mid frequencies. It looks like SWYH cuts frequencies during the encoding process.
When I play the same tracks directly through Sonos player, they sound perfectly and no issues with bass frequencies.

Has anybody noticed that?


#8

In the settings of SWYH, change the bitrate to the highest one in the list. It dramatically improves the quality.


#9

Same here. It seems to work just fine except for the sound quality. It sounds too tinny and lacks depth.

Does the SWYH team have a solution to this?


#10

Hey
I am using Sonos Play 1 and i tried to use Stream-What-You-Hear. I have tried with the specific port number but still when i try to play via Sonos via its PC controller v5.2 it gives an error saying unable to connect to swyh.mp3 - cant connect to my http live streaming link (http://192.168.1.111:8080/stream/swyh.mp3)
Please help.


#11

Hey,

I had the same issue (the lack of depth in the streamed audio)…
After some googling and testing, I found out that it was not a SWYH problem but a problem caused by the IDT SRS audio-software that was - by default - installed on my (HP) laptop.
I uninstalled the IDT software and now everything sounds fantastic!


#12

Sunny,

I’m not 100% sure that it will solve your problem, but I would advice you to select a new port number: port 8080, which you use, is a port that is used for http-traffic.
Probably your Sonos device uses this port for its http-traffic and it is therefore not able to access your audio-stream.

I use port 5901 on a Sonos Play1: works flawless!


#13

Absolutely awesome! I can only get it to play in 192k mp3 mode but I wonder if thats just the setting. Because playing flac in this mp3 mode sound FANTASTIC. If I use a higher mp3 settings I get latency and choppy sound. Not complaining though. Thank you!!!

H.


#14

UPDATED (same day):

After you set the port to what came up automatically and SWYH restarts, you need to go to TuneIn Radio in Sonos, and edit the station you created to reflect the new port.

I got the port sorted (I think) but I now get an error message saying "unable to connect to 192.168.1.3:49317

Any suggestions?

Thank you.


#15

I confirm Tim’s suggestion. I also removed this IDT package from my HP-Probook.
From now the sound is great on my Sonos.


#16

Hi,
I’ve managed to successfully set up SWYH on one of my computers and it works very well… Thanks for such a great product.

I’ve tried to set it up on my wife’s computer and I keep getting the error message "Unable to play ‘swyh.mp3’ - the song is not encoded properly. I was getting this error on mine before I set it up properly. I’m sure I set it up properly on her computer, but obviously I’ve done something wrong OR there is something stopping me setting it up on a second computer…

Are you able to help me at all?
Thanks
Michael


#17

SWYH works beautifully Thanks for all the tips. I experience a little latency but I have to play with config sure I can improve it. I"m a total Rookie so it took a while to figure out how to Config it.
To help other Rookies here it is:

  1. Install the SWYH APP: Rightc Click the Quick link SWYH
  2. In SWYH Select Tools, Select HTTP Live Streaming, Another Box will popup with a Local Link
  3. Copy that link
  4. Go to Sonos App, Under Manage Menu, Select Add Radio Station
  5. Paste The local link you created from the Pop up window “SWYH HTTP live Stream URI” into link line, and Named it
  6. The Radio Station will show under “My Radio Stations” Select this when you want to stream to Sonos
    Thanks

#18

Hi,
I’ve installed SWYH, I think, but when I click on the icon it says its already running. I’ve tried restarting my computer, which is windows 10, and it still says that. Can you help?


#19

hello
@fran

click bellow on the right on the icon you have the setup